Introduction à l’IDE Arduino

Review et partage :

Introduction Objectif

Description

Entrer dans le mouvement « Maker » est aujourd’hui à la portée de tous et les projets articulés autour de l’électronique sont de plus en plus présents sur le net. Tout le monde à déjà entendu parler des composants Arduino et de leur facilité d’utilisation mais il ne faut pas négliger la partie cachée de l’iceberg. Pour que tout cela fonctionne et pour donner vie à vos projets vous aurez besoin, à un moment ou un autre, de programmer vos composants à l’aide d’un logiciel dédié à savoir, l’Arduino IDE.

Objectifs

Dans ce guide nous n’écrirons pas de code mais ferons le tour des fonctionnalités et raccourcis du logiciel afin de l’utiliser efficacement. Nous verrons également comment installer des librairies : des « extensions » à notre code qui nous permettront d’y ajouter des fonctionnalités.

Tour du propriétaire

Dans ce chapitre nous allons passer en revue les différentes zones de l’interface graphique de l’Arduino IDE.

Les onglets :

lesonglets

Le logiciel est doté des onglets habituels que l’on retrouve dans la quasi totalité des logiciels, à savoir le bouton “Fichier”, “Edition” et “Aide”. C’est par exemple par l’onglet Fichier que vous devrez passer pour créer un croquis, en ouvrir un déjà existant, parcourir les différents exemples ou encore éditer les différents exemples.

Les onglets que vous utiliserez principalement sont Croquis et Outils. Sous “Croquis” vous trouverez les options pour compiler et téléverser votre code. Inutile cependant de venir jusque ici pour le faire puisque vous trouverez des raccourcis pour ces commandes dans la fenêtre principale de l’application.

C’est aussi sous cet onglet que vous pourrez gérer et importer vos librairies sur lesquelles nous reviendrons plus en détail dans le chapitre suivant.

Dans l’onglet Outils vous trouverez, entre autres, toutes les options liées à votre micro-contrôleur, il faudra par exemple prendre soin de sélectionner le bon modèle de votre carte ainsi que le bon port auquel cette dernière est branchée.

Certaines cartes comme par exemple le Trinket ou le Gemma de chez Adafruit nécessitent aussi un programmateur, dans ce cas il faudra également sélectionner le bon dans le menu approprié.

La fenêtre principale :

fenetre2

L’IDE est construit autour d’un éditeur de texte où vous pourrez écrire votre code directement. La première barre est constituée de raccourcis vers les fonctions les plus utilisées que l’on vient de voir dans les onglets. Une fois votre code écrit, vous pourrez par exemple le compiler avec le bouton (1) et ainsi en vérifier les erreurs.

Si le code ne retourne pas d’erreur vous pouvez alors l’uploader ou le “téléverser” en français (oui, c’est pas terrible) sur l’Arduino en appuyant sur le bouton (2).

1verifierCompilation et vérification des erreurs de votre code
2televerser-e1441100715593Téléversement de votre code vers le micro-contrôleur

S’il y a une ou plusieurs erreurs dans votre code, vous en trouverez le détail dans la console devenue orange pour l’occasion et la ligne concernant l’erreur sera surlignée en rouge comme illustré ci-dessous.

error

Sachez que lors d’un téléversement (oui, toujours pas terrible) le code est automatiquement compilé, il est donc inutile de le faire avant chaque upload. Une fois le code téléversé avec succès, celui-ci sera exécuté par le micro-contrôleur tant qu’il sera alimenté par du courant.

Vous trouverez ensuite les raccourcis de création et de sauvegarde comprenant :

  • Un bouton pour ouvrir un nouveau croquis (3). Celui-ci sera vide à l’exception de la déclaration des fonctions primordiales au bon fonctionnement de l’arduino.
  • Un bouton pour ouvrir un croquis existant (4). Bien que sa présence soit appréciée, il est parfois plus rapide d’aller dans l’onglet Fichier pour y trouver les croquis récents sur lesquels vous avez travaillé dernièrement, fonction inexistante en cliquant sur le raccourci.
  • Un bouton Enregistrer (5) qui parle de lui même. Notez qu’en cliquant sur ce bouton vote code sera enregistré en écrasant le code précédent. N’hésitez donc pas à court-circuiter ce raccourci pour forcer un nouvel enregistrement avec le bouton « Enregistrer sous ». Cela vous permettra de garder un historique de votre code et de garder les versions antérieures
  • Un bouton unique (6) permettant d’ouvrir le moniteur série. Celui-ci va nous servir à communiquer avec notre contrôleur pendant qu’il exécute notre code. On pourrait par exemple lui envoyer des commandes ou lui demander de communiquer des valeurs  qu’il aura relevé. Cette communication devra bien entendu être prévue dans le code.
3nouveauCréation d’un nouveau croquis
4ouvrirOuverture d’un croquis existant
5enregistrerEnregistrement du croquis
6moniteurOuverture du moniteur série

 

La seconde barre est la barre d’onglet de votre code :

onglets

Il vous est en effet possible de diviser votre code en onglet pour des raisons d’organisation. Les onglets sont alors regroupés en partant de la gauche. Le bouton de droite (7) vous permet quant à lui de renommer, supprimer, créer et parcourir ces onglets.

7tip-e1441459227378Contrôle des onglets

Vous pouvez appeler une fonction d’un onglet à l’autre sans écriture supplémentaire, au moment de la compilation, tout ces onglets seront alors regroupés dans un « SUPER CROQUIS ».

Bien que ce soit une bonne habitude à prendre, cette fonctionnalité sera surtout utile lorsque vous aurez un code trèèès long, où il sera nécessaire de séparer les fonctionnalités pour s’y retrouver. Elle le sera moins pour le commun des mortels comme vous et nous qui réaliseront des codes de quelques dizaines de lignes seulement.

En parlant de longueur de code, vous trouverez dans la dernière ligne de la fenêtre à gauche le numéro de la ligne où se trouve votre curseur actuellement. Cette indication sera notamment utile lorsque que la console située juste au dessus vous retournera une erreur puisque celle-ci vous donnera la ligne d’où provient l’erreur.

derniere-ligne

Sachez cependant qu’il vous est possible d’afficher un numéro devant chaque ligne pour encore plus d’efficacité depuis Fichier > Préférences.

numero-cote

Et enfin, à droite de cette dernière ligne vous trouverez la carte actuellement configurée et le port sur lequel celle-ci est connectée.

carte

Il est important que ces deux valeurs soient bonnes pour que le code se téléverse correctement. Ce ne sera pas un problème pour les cartes Arduino et les précisées compatibles mais il faudra par exemple sélectionner Arduino UNO pour programmer sur un Adafruit Metro. Certaines cartes demandent un effort supplémentaire puisqu’il faudra installer les drivers correspondants pour pouvoir téléverser du code dessus. Dans ce cas, la procédure d’installation et le liens vers ces drivers seront disponibles dans les guides de ces cartes.

Les librairies Arduino

Maintenant que l’interface graphique est maîtrisée, passons aux choses sérieuses avec les librairies Arduino.

Les librairies Arduino vous permettront d’inclure plus de fonctionnalités dans votre code Arduino.

Si vous voulez par exemple inclure un servo moteur, un neopixel, un lecteur de carte SD ou juste réaliser quelque chose de très spécifique, il vous sera nécessaire d’utiliser des fonctions qui ne sont pas supportées par l’Arduino IDE de base.

Des librairies sont donc créées par les constructeurs ou utilisateurs pour ces éléments contenant toutes les fonctions nécessaires pour les faire fonctionner. Il vous arrivera sûrement un jour de copier-coller un code sur Internet et d’avoir la surprise que ce code vous retourne une erreur lors de sa compilation.

 

“Comment ?! Le code ne fonctionne pas ?!? Internet m’a menti ?!?!”

                                                                                                    – Un copieur-colleur

 

Non, pas nécessairement. Il est très probable qu’il vous manque justement la librairie adéquate pour faire fonctionner ce code.

Essayez par exemple d’inclure la ligne suivante dans un nouveau code juste au dessus de la fonction setup :

Adafruit_NeoPixel strip = Adafruit_NeoPixel(3, 2, NEO_GRB + NEO_KHZ800);

 

Cette ligne permet la mise en place d’une bande de neopixels d’une longueur de 3 leds en Pin 2, si vous essayez de compiler ce code, il vous retournera une erreur. Pourtant cette ligne n’est pas fausse, elle n’a juste aucun sens aux yeux de l’IDE Arduino.

C’est un peu comme lorsque vous demandez à un ami de prendre un couteau dans le tiroir. Non seulement il faut que vous ayez un tiroir qui contienne des couteaux, mais il faut indiquer à votre ami quel est le bon tiroir, sinon il essaiera de prendre un couteau dans le premier tiroir venu avant de vous dire que le couteau n’existe pas.

Ces librairies se présentent sous la forme de fichiers et se trouvent dans deux répertoires Arduino spécifiques :

  1. Document/Arduino/librairies où vous mettrez vos librairies personnelles
  2. Racine du programme Arduino/librairies pour les librairies installées par défaut.

Pour les utiliser, il suffira d’indiquer leurs utilisations à Arduino en les incluant par le biais d’une ligne qui ne vous sera peut-être pas inconnue :

#include <Servo.h>

 

“Je te préviens, je vais utiliser des fonctions spécifiques à la librairies du servo, donc ne 

t’étonnes pas si il y a quelque chose que tu ne connais pas, ça sera sûrement là dedans.”

                                                                                                  – la commande #include

Vous pouvez voir les librairies actuellement installées dans votre Arduino en allant dans le menu Croquis > Include Library.

menu

Vous aurez ici une liste déroulante de vos librairies disponibles et déjà utilisables. Vous en trouverez quelques unes qui sont installées par défaut comme par exemple celle du Servo. Si la librairie que vous voulez utiliser est dèjà présente dans cette liste, vous pouvez directement l’utiliser. Si ce n’est pas le cas il va falloir l’installer et dans ce cas, il y a deux possibilités.

 

Première possibilité : La librairie désirée se trouve sur l’Arduino Library Manager.

 

L’Arduino Library Manager est disponible depuis la version 1.6.2 d’Arduino IDE, si vous n’êtes pas sur cette version, vous n’y aurez pas accès et il vous faudra procéder à une mise à jour du logiciel.

Le manager référence les librairies existantes qui ont été proposées par des utilisateurs et ayant été acceptées par Arduino (un peu comme sur votre téléphone portable avec les apps) . Il facilite grandement l’installation de ces dernières car une fois la librairie trouvée, l’installation est automatique.

Pour accéder à ce manager, rendez vous dans Croquis > Include Library > Library Manager.

Une fenêtre s’ouvrira avec la liste des librairies référencées.

Vous pouvez alors trier ces librairies par auteur et fonctionnalité ou procéder à une recherche sur base d’un mot clé à l’aide de la barre de recherche.

manager-1

Lançons nous donc et installons la librairie permettant d’utiliser les Neopixels d’Adafruit.

Nous allons donc taper “Neopixel” dans la barre de recherche. D’après la description, celle qui nous intéresse est “Adafruit NeoPixel”.

Vous pouvez alors cliquer dessus, sélectionner la dernière version et cliquer sur “Install”.

Le Manager se chargera ensuite de télécharger et installer la librairie.

Deuxième possibilité : La librairie n’est pas disponible sur le Manager

 

Comme expliqué plus haut, le manager ne référence que certaines librairies et il vous faudra souvent passer par Internet pour trouver celle que vous cherchez et l’installer vous même.

Prenons l’exemple de la librairie IRremote qui permet l’utilisation de LEDs et récepteur infrarouge. Celle-ci ne se trouve pas sur le Manager, je vais donc la chercher sur Internet via notre ami Google.

La plupart du temps vous trouverez les librairies directement sur Github, un site permettant aux développeurs de facilement distribuer leurs codes. Ne vous laissez pas impressionner par son interface, vous êtes au bon endroit.

https://github.com/z3t0/Arduino-IRremote

Une fois sur la page de la librairie, vous pouvez la télécharger au format zip grâce au bouton dédié à droite.

github

Rendez vous alors sur l’IDE Arduino dans Croquis > Include Library > Add .ZIP Library

Sélectionner donc l’archive que vous venez de télécharger pour l’installer.

Vous pouvez également décompresser l’archive vous-même et la copier dans :

Document\Arduino\libraries

Le résultat sera le même mais requerra un redémarrage de l’IDE.

L’utilisation d’une librairie :

 

Une fois la librairie installée, vous pouvez l’inclure en vous rendant dans Croquis > Include Library et en cliquant sur la librairie souhaitée.

Vous verrez tout de suite s’ajouter en haut la ou les lignes correspondantes. Rien ne vous empêche de les écrire manuellement si ce n’est la prévention de fautes et la certitude que les librairies sont bien installées dans l’IDE.

Vous pouvez désormais utilisez les fonctions liées à cette librairie. Ces fonctions sont vraiment propres aux librairies pour apprendre à les utiliser il faudra donc vous tourner vers la notice d’utilisation (encore une fois souvent sur Github) ou étudier les exemples/démos qui sont, la plupart du temps, inclus dans les librairies.

Dans notre prochain guide nous vous expliquerons les bases de la programmation avec l’Arduino IDE en se basant sur un code existant et nous en profiterons pour créer notre propre code contenant les fonctions les plus utiles…

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *